Quantcast

Jump to content


Photo

Neoquest's Neoquest II AP


  • Please log in to reply
298 replies to this topic

#51 DoNotAnnoyMe

DoNotAnnoyMe
  • 157 posts

Posted 19 February 2012 - 09:57 PM

If you're concerned about me sending your account information to myself and clearing your account of all it's wonderful goodies, you need not worry. I wouldn't trade my account on this forum for a couple million neopoints, I hardly even play the game anymore.


it's not that I'd be bothered really and I doubt you'd do anything harmful, but it's still... dunno
I just don't see why people hate it so much to share a script instead of a binary, especially for something that already has a ton of scripts out there (except not wanting anyone to see their weird code style :p)
anyway, still good job - I suppose *shrugs*

#52 Senrath

Senrath
  • 305 posts

Posted 19 February 2012 - 10:25 PM

I did state that it wasn't needed in the OP :whistling:

Well, there's a big difference between "not needed" and "will break things if done". The former implies that you can do it, you just don't have to, while the latter (which is what this case is) says that you can't do it without messing things up.

Edited by Senrath, 19 February 2012 - 10:25 PM.


#53 Neoquest

Neoquest
  • 1,682 posts


Users Awards

Posted 19 February 2012 - 10:58 PM

it's not that I'd be bothered really and I doubt you'd do anything harmful, but it's still... dunno
I just don't see why people hate it so much to share a script instead of a binary, especially for something that already has a ton of scripts out there (except not wanting anyone to see their weird code style :p)
anyway, still good job - I suppose *shrugs*


Actually the main reason I don't release the script itself is because I don't want people to have to deal with installing Python/figuring out all that jazz. Plus the weird code style :p

Well, there's a big difference between "not needed" and "will break things if done". The former implies that you can do it, you just don't have to, while the latter (which is what this case is) says that you can't do it without messing things up.


Alright, I've made it idiot proof for the next release.

#54 DoNotAnnoyMe

DoNotAnnoyMe
  • 157 posts

Posted 19 February 2012 - 11:02 PM

Actually the main reason I don't release the script itself is because I don't want people to have to deal with installing Python/figuring out all that jazz. Plus the weird code style :p


would help mac and linux guys, tho :p
and weirdos like me who like to see how weird python actually looks *chuckles*

#55 Neoquest

Neoquest
  • 1,682 posts


Users Awards

Posted 19 February 2012 - 11:08 PM

would help mac and linux guys, tho :p
and weirdos like me who like to see how weird python actually looks *chuckles*


I don't think this would work initially with Mac, though I'm not sure about Linux. As I said earlier I tried it briefly with my MacBook Air. The code looks surprisingly readable, I made a TON or comments. Everywhere. I could have used about half as many lines, but didn't for sake of readability.

#56 ahding

ahding
  • 40 posts

Posted 20 February 2012 - 02:45 AM

Can you be more spesific about what you do, what do you expect and won't happen? Maybe we can help you that way. Because i have been using training mode for more than 4-5 hours and nothing went wrong. Also be sure you are on an area that mobs can attack you before you start training mode. If program confuses you, just log to neopets manually, go to an area with mobs, then run the program for the training mode.

EDIT: In trainer mode, program stops time to time and i have to rerun it manually once it stops. Sometimes it even just keeps showing refresh times but nothing else, eventhough im in the middle of a training area, again i close and run the program once more to make it work properly.


okay thanks alot it helps

#57 Jun

Jun
  • 907 posts

Posted 20 February 2012 - 03:01 AM

Glad it helped. Between program started to act up more than yesterday. Whenever I leave it to training mode, within 10-15 minutes it starts to only send refresh times forever. It happens in the middle of fights. I close the program when it happens and log to game, always find my characters in the middle of a fight. It may occur because of 3-4 packs of mobs my party is dealing with. (I have 3 heroes right now) If it wasnt luck, it always happened in such fights, and 1-2 mobs were defeated.

Edited by Junjun, 20 February 2012 - 03:09 AM.


#58 SlaughterHouse

SlaughterHouse
  • 34 posts

Posted 20 February 2012 - 03:03 AM

The program works great thanks!

I found a little problem with the auto mover using a script. It will move for a while and then suddenly stop in the middle of a fight and just keep looping out wait times without doing anything in the fight or moving. So I think there might be a problem in fighting when using a move script as this has never happened in training mode.

EDIT:

Junjun just posted at same time as me but my problem isn't the script dealing with multiple mobs I am not at such a point yet it is dealing with single mobs.

Edited by SlaughterHouse, 20 February 2012 - 03:04 AM.


#59 Jun

Jun
  • 907 posts

Posted 20 February 2012 - 03:10 AM

The program works great thanks!

I found a little problem with the auto mover using a script. It will move for a while and then suddenly stop in the middle of a fight and just keep looping out wait times without doing anything in the fight or moving. So I think there might be a problem in fighting when using a move script as this has never happened in training mode.

EDIT:

Junjun just posted at same time as me but my problem isn't the script dealing with multiple mobs I am not at such a point yet it is dealing with single mobs.


It happened to me with single mobs too, but so rarely. Now im having that problem every 10-15 min.

EDIT: Extra info; just happened again, with 2 mobs, non of them were dead when i logged and checked.

EDIT 2: Happened again, logged and see 3/3 mobs alive in the fight. Should i keep collecting more data to help solving this problem?

Edited by Junjun, 20 February 2012 - 03:34 AM.


#60 SlaughterHouse

SlaughterHouse
  • 34 posts

Posted 20 February 2012 - 04:55 AM

It happened to me with single mobs too, but so rarely. Now im having that problem every 10-15 min.

EDIT: Extra info; just happened again, with 2 mobs, non of them were dead when i logged and checked.

EDIT 2: Happened again, logged and see 3/3 mobs alive in the fight. Should i keep collecting more data to help solving this problem?


I don't know if this is anything to do with it but it might be to do with the healing method? It seems to always get stuck just after healing for me, is it the same for you?

#61 Jun

Jun
  • 907 posts

Posted 20 February 2012 - 05:07 AM

I don't know if this is anything to do with it but it might be to do with the healing method? It seems to always get stuck just after healing for me, is it the same for you?


Didn't pay attention to that, let me run the program and check it.

#62 SlaughterHouse

SlaughterHouse
  • 34 posts

Posted 20 February 2012 - 05:12 AM

Didn't pay attention to that, let me run the program and check it.


Might be part of it but mine just stopped again but this time instead of healing it had defeated the mob I logged in to check and mob was dead but fight wasn't ended.

#63 Jun

Jun
  • 907 posts

Posted 20 February 2012 - 05:14 AM

Might be part of it but mine just stopped again but this time instead of healing it had defeated the mob I logged in to check and mob was dead but fight wasn't ended.


Check your last move? I checked once, last attack was by Mipsy, group damage and it was Rohane's turn. Lets share our data and try to find the exact problem.

Edited by Junjun, 20 February 2012 - 05:14 AM.


#64 Turnip

Turnip
  • woomy woomy manmenmi!!

  • 2,487 posts


Users Awards

Posted 20 February 2012 - 06:02 AM

Whoa, this sounds fantastic!! I'll have to try it out some time~ :) *always gets super bored after playing it for a few minutes*

+rep!



#65 Neoquest

Neoquest
  • 1,682 posts


Users Awards

Posted 20 February 2012 - 07:41 AM

I think something went wrong with the way the program discerns whether the fight is over, I've fixed this for the new release, and added an infinite loop safeguard.

#66 Jun

Jun
  • 907 posts

Posted 20 February 2012 - 02:03 PM

I made it to last act in 2 days. I can clearly say you can finish NQ2 Normal mode in 3 days with this AP. It wouldnt take more than 10-12 days to get the gold trophy if you keep playing NQ2 everyday using this AP. I haven't tried but i wonder, can we run this AP for more than 1 account at the same time? It would provide a great profit to run like 10 APs with 10 different accounts at the same time :p

#67 Neoquest

Neoquest
  • 1,682 posts


Users Awards

Posted 20 February 2012 - 05:18 PM

I made it to last act in 2 days. I can clearly say you can finish NQ2 Normal mode in 3 days with this AP. It wouldnt take more than 10-12 days to get the gold trophy if you keep playing NQ2 everyday using this AP. I haven't tried but i wonder, can we run this AP for more than 1 account at the same time? It would provide a great profit to run like 10 APs with 10 different accounts at the same time :p


I wouldn't suggest it without a Proxy. I can imagine how that would be incredibly profitable though.

#68 L33T

L33T
  • 861 posts


Users Awards

Posted 20 February 2012 - 08:22 PM

Thanks! Your name and the fact you made this program is very ironic :shifty:

=^-^= +rep

#69 Neoquest

Neoquest
  • 1,682 posts


Users Awards

Posted 20 February 2012 - 08:50 PM

Thanks! Your name and the fact you made this program is very ironic :shifty:

=^-^= +rep


Wouldn't that be the opposite of irony?

#70 Norava

Norava
  • Pro Can Cran

  • 541 posts


Users Awards

Posted 20 February 2012 - 09:17 PM

Thanks! Your name and the fact you made this program is very ironic :shifty:

=^-^= +rep


Maybe if his name was "iHateNeoquest".

#71 Neoquest

Neoquest
  • 1,682 posts


Users Awards

Posted 20 February 2012 - 10:04 PM

Maybe if his name was "iHateNeoquest".


But then I would be lying.

Updated to version 0.7. Loop bug should now be fixed, the program should at least be generating a file with the source code of the page it it happens again. If I get some confirmation that it is fixed, I'll be adding some features that include ability to finish the whole game in one sitting.

#72 Jun

Jun
  • 907 posts

Posted 21 February 2012 - 03:40 AM

But then I would be lying.

Updated to version 0.7. Loop bug should now be fixed, the program should at least be generating a file with the source code of the page it it happens again. If I get some confirmation that it is fixed, I'll be adding some features that include ability to finish the whole game in one sitting.


Started to test it now, i ran it like 3 min, after a fight, it said "Can't find anything to do!", stopped for about 30 sec and continued to work properly. I guess it fixes itself during that 30 sec?

Good job again, i really liked this AP.

Will you add an option to use different proxies later?

EDIT: That refresh time delay spam happened again, but this time, after a minute, again program started to work properly and continued the fight. I can confirm problem is fixed. Again i'll let you know if something wrong happens, i'll keep it working next 3-4 hours.

Edited by Junjun, 21 February 2012 - 04:00 AM.


#73 Neoquest

Neoquest
  • 1,682 posts


Users Awards

Posted 21 February 2012 - 07:11 AM

Started to test it now, i ran it like 3 min, after a fight, it said "Can't find anything to do!", stopped for about 30 sec and continued to work properly. I guess it fixes itself during that 30 sec?

Good job again, i really liked this AP.

Will you add an option to use different proxies later?

EDIT: That refresh time delay spam happened again, but this time, after a minute, again program started to work properly and continued the fight. I can confirm problem is fixed. Again i'll let you know if something wrong happens, i'll keep it working next 3-4 hours.


What do you mean by use different proxies? Those thirty seconds are when the page doesn't load, it just waits 30 seconds and then tries again. And if it finds for some reason that it gets stuck and doesn't know why, it will be able to flee the battle and keep training :D

#74 SlaughterHouse

SlaughterHouse
  • 34 posts

Posted 21 February 2012 - 08:50 AM

What do you mean by use different proxies? Those thirty seconds are when the page doesn't load, it just waits 30 seconds and then tries again. And if it finds for some reason that it gets stuck and doesn't know why, it will be able to flee the battle and keep training :D


It doesn't work at all for me now, It'll move around when I turn on Autotrainer as usual encounter fights, then it'll start fighting then before it kills the mob it'll flee from the fight then about 4 seconds later print out "You have won the battle" Gaining no xp or killing anything.

#75 Jun

Jun
  • 907 posts

Posted 21 February 2012 - 09:16 AM

What do you mean by use different proxies? Those thirty seconds are when the page doesn't load, it just waits 30 seconds and then tries again. And if it finds for some reason that it gets stuck and doesn't know why, it will be able to flee the battle and keep training :D


I'd love a proxy setting option in the program to run 10 different accounts with 10 different proxies, thats what i meant :p Also, program works perfect for me, except i didn't realise Mipsy died and now she is 2 levels less than others..

Edited by Junjun, 21 February 2012 - 09:16 AM.



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users