Quantcast

Jump to content


Photo

Stuck on the loading screen.

why is the battledome so damn bad nothing ever works

  • Please log in to reply
7 replies to this topic

#1 willytung

willytung
  • 53 posts


Users Awards

Posted 09 April 2014 - 08:32 PM

The rest of the website works fight but I am constantly getting stuck at the loading screen.



#2 Fikri

Fikri
  • submissive


  • 4,433 posts


Users Awards

Posted 09 April 2014 - 08:37 PM

did someone say my name??  :p

 

just checked. it's working fine to me. some status updates are saying that neopets is down, so maybe it has something to do with it.



#3 willytung

willytung
  • 53 posts


Users Awards

Posted 09 April 2014 - 08:45 PM

This sucks. Just wanted to test the damage of a new bow I bought from the shops.



#4 Fikri

Fikri
  • submissive


  • 4,433 posts


Users Awards

Posted 09 April 2014 - 09:01 PM

i think you can just calculate that. :p

 

we have a battledome simulator in codex i believe but i don't know how to operate it.



#5 Waser Lave

Waser Lave

  • 25,516 posts


Users Awards

Posted 10 April 2014 - 08:03 AM

i think you can just calculate that. :p

 

we have a battledome simulator in codex i believe but i don't know how to operate it.

 

Our battledome simulator was based on the old version so it's not likely to be accurate any more. :p



#6 conductonator

conductonator
  • 37 posts


Users Awards

Posted 24 May 2014 - 09:06 AM

Try refreshing. Same thing was happening to me, but after a constant refresh, or waiting for some time, it started working again.



#7 HungryForNoms

HungryForNoms
  • 27 posts

Posted 30 May 2014 - 02:58 PM

Try refreshing. Same thing was happening to me, but after a constant refresh, or waiting for some time, it started working again.

Yup.. the battledome is buggy, refreshing is the way to fix this problem. Usually my fights just go right on ahead like nothing ever stopped them to begin with.



#8 Xstorm

Xstorm
  • 27 posts


Users Awards

Posted 02 June 2014 - 06:32 AM

It happened to me a few times. i just cleared all the browser files and it worked out.





Also tagged with one or more of these keywords: why, is, the, battledome, so, damn, bad, nothing, ever, works

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users