Quantcast

Jump to content


Photo

Neo Tracker Not Updating?


  • Please log in to reply
7 replies to this topic

#1 zex

zex
  • 214 posts


Users Awards

Posted 07 February 2019 - 01:39 PM

I tried using search but didn't find anything on this. I've recently gotten back into Neopets due to the stupidest /r/legaladvice topic ever, and have kicked up my Abrosia. I've noticed even though I have my Abrosia set to log to neotracker under the correct profile, it doesn't seem to have done so. Nothing has updated since around December(I only took January off of Neo).

 

Is this something I'm doing wrong?



#2 Strategist

Strategist
  • Sadmin

  • 9,688 posts


Users Awards

Posted 07 February 2019 - 10:36 PM

@Pyro699 may be able to assist. A couple of other users have been experiencing the same issue and he's been able to fix it for them too.



#3 zex

zex
  • 214 posts


Users Awards

Posted 08 February 2019 - 08:55 AM

Moderately glad it's not just me. :p I kept checking my settings and my VPN and could not piece together what was happening. 

 

Not game breaking or anything, just a nice thing to have, mostly since I don't pay attention to my purchases anymore.



#4 Pyro699

Pyro699
  • 1,484 posts


Users Awards

Posted 08 February 2019 - 09:32 AM

Could you provide me with a screenshot of what you are seeing and how you see that your results are not there? I see that you have 808 buys under profile "Zidormi" and a bunch of other information under the accounts...

Your stats should update at the following times:
Buys: 3AM UTC
Sales: 7AM UTC
Bank: 11AM UTC

I was not able to find any issues
Actually, I take that back.... There might be something wrong with the entirety of the cronjobs on the server Your data is all there, it is just failing to properly cache things now, whoopee. I wrote myself a small script to manually run ALL of the cronjobs, and will periodically run it until i find the source problem.

#5 zex

zex
  • 214 posts


Users Awards

Posted 08 February 2019 - 09:35 AM

Attached the latest dates for my sales log and my buy log. Looks like it may just be a GUI issue then. I attempted to hard refresh and cleared my cache and it didn't update the stats.

 

Good to know the data is there though. :)

 

Edit: Not sure if you ninja edited or if I can't read, but eww cronjobs. I need to provide some cookies for you. I have a joke in my work that says "Linux is only free if you don't value your time." :p 

Attached Files


Edited by zex, 08 February 2019 - 09:37 AM.


#6 Pyro699

Pyro699
  • 1,484 posts


Users Awards

Posted 08 February 2019 - 11:58 AM

I mean, most of the world runs on some kind of linux subsystem :p If you are suggesting i should use some nice windows or mac guis - ill stick with my clis thankyou xD
Also - looking at your buy logs in the mysqldb... you had some buys on Dec 20 2018 and then the next ones are on January 7th - can you try again :)
I have gone ahead and added a bunch of new logging, lets wait a day or two and see how things go. It might break again.

#7 zex

zex
  • 214 posts


Users Awards

Posted 08 February 2019 - 05:47 PM

It looks like it's working again. :) Thank you for the prodding of the DB.

 

I also never said Windows or Mac was better. They are all terrible in their own ways. :p Thus is life.

 

Thank you again!! :D



#8 Pyro699

Pyro699
  • 1,484 posts


Users Awards

Posted 09 February 2019 - 01:44 PM

I did find an issue, the cronjobs are not running - even though they are in the right folder and format. I will look into this tonight, however until I do that, I will need to manually run the script to do the caching. I will try to remember to do it once a day :)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users