Quantcast

Jump to content


Photo

Neopets Game Helpdesk


  • Please log in to reply
14 replies to this topic

#1 Warlord

Warlord
  • 3,988 posts

Posted 14 June 2007 - 11:18 AM

This is the official place to go to if you need help on neopets games. Stuck on level 1? Can't get past that irksome boss? Don't know what stock to buy? If you have a question about neopets games that isn't covered in the guides then ask it here and we'll answer it smile.gif

#2 Squishee

Squishee
  • 67 posts

Posted 29 August 2007 - 07:11 PM

I have a question about deck swabber/ stowaway sting, how do you get dubloons from there, because capn threelegs said you can get dubloons from there, and I have a hard time getting past the third level...

#3 Sasha

Sasha
  • 633 posts

Posted 29 August 2007 - 10:38 PM

I don't know about Stowaway Sting, because I've only tried it once, but Deckswabber used to give out dubloons a long time ago, when it appeared on the site, and I think that's no longer available.
Just like Pterattack used to give out a PetPet or a valuable plushie (can't remember which one). But that was years ago.

#4 Lawivido

Lawivido
  • iOS Hacker

  • 2,018 posts


Users Awards

Posted 30 August 2007 - 12:54 AM

What's intelligence for?

#5 Squishee

Squishee
  • 67 posts

Posted 30 August 2007 - 06:30 PM

QUOTE(Kitsune @ Aug 30 2007, 01:02 AM) View Post
First off... deckswabber the game doesn't exist anymore, they took it off and apparently the avatar is retired (boo).
I thought it was dubloon disaster that used to give out dubloons, but at any rate, no longer does this.

Intelligence is not really used for anything. I believe there is a particular battledome item (some robe which I don't recall the name of) which requires a certain level of intelligence, but it's not a good item anyway, and int doesn't aid you in any other way.


If deckswabber doesn't exist anymore shouldn't they edit there sayings for capn threelegs... grrr they need to keep up a little better I guess... mad.gif:

Thank you though n_n

Edited by Squishee, 30 August 2007 - 06:31 PM.


#6 Squishee

Squishee
  • 67 posts

Posted 30 August 2007 - 07:25 PM

I guess hardly ever..... They should make games that give you dubloons, do they expect for a lot of them to appear everywhere... for every single person

#7 Sasha

Sasha
  • 633 posts

Posted 30 August 2007 - 11:09 PM

You can get some from Coltzan's Shrine, if your active pet's level isn't very high. I get them quite often.

#8 Wiggly_tug

Wiggly_tug
  • 15 posts

Posted 26 September 2007 - 12:52 PM

Intelligence is for Heavy Robe Of Thievery
Requires over 100 Intelligence and 200 movement.
100% steal, once per battle
Also it is used in an intelligence contest or something.

#9 Sasha

Sasha
  • 633 posts

Posted 26 September 2007 - 02:26 PM

QUOTE(Wiggly_tug @ Sep 26 2007, 11:52 PM) View Post
Also it is used in an intelligence contest or something.


From what I know, it serves for the book award which your pet gets for having read almost any book in existence. So it's no use having 1000 intelligence from, say, Cliffhanger.


#10 ElPinapple

ElPinapple
  • 204 posts

Posted 07 June 2011 - 08:34 AM

Is there a Pyramids strategy?

I can't seem to clear it... :/

#11 jcrboy

jcrboy
  • Oh shit there's a thing here

  • 6,953 posts


Users Awards

Posted 07 June 2011 - 08:51 AM

Is there a Pyramids strategy?

I can't seem to clear it... :/


We have a program that plays for you.... use it... but it usually takes a while (about 1/50 games clears the pyramid?).

#12 MarvelGirl

MarvelGirl
  • 205 posts


Users Awards

Posted 15 December 2011 - 11:13 AM

Mystery Pic Question:

My MP games has not worked for over three years. When I submit my answer I get a red box that says "Opps, it looks like you have already submitted your answer for this round".

So I contact TNT with all the information about the glitch, I am using Windows XP.

I get a reply back stating I need to update my system. So I go thru and double check everything, all updates, clear all my junk etc and still cannot play. So I submit the ticket again and get the same reply "Update your system", I do it again same results.

This time TNT reply's "as mentioned before, update your system" . Well, hell I am updating and have auto update and finally give up asking TNT.

Soooo now I am on a laptop with Windows 7 and guess what, I still cant submit an answer for the MP. From what I hear there are a lot of players with the same problem.

Does anyone here know about this glitch and/or if anyone has had any success in fixing the problem?

#13 miatreadway

miatreadway
  • 2 posts

Posted 30 June 2015 - 04:39 PM

I have a question about a Neopet game, but I'm not looking for a guide on how to complete it. I'm not sure of where else to put this so if this topic isn't the appropriate place for it, I do apologize. Anyway, I completed today's Faerie Crossword puzzle and found a question that isn't on the Neo Log. How do I submit the question and answer so that it's added to the log? Again, sorry if this isn't the right place for this question.



#14 KyloRen

KyloRen
  • Snoke says I'm special.



  • 5,124 posts


Users Awards

Posted 30 June 2015 - 07:13 PM

I don't think many people use the log anymore. I checked thinking it might be an adv+ or above member function, it isn't. It looks like there isn't a way to update the log anymore. Honestly, the most used logs we have would be the avatar log and the lab zap log. If you look at the other logs, you'll noticed none of them are really updated at all anymore, and that's probably why there doesn't seem to be an update function anymore. Not enough people may be using that log..

 

Also, the last post in this topic was from 2011....so I have no idea how you found a topic from over 4 years ago...



#15 miatreadway

miatreadway
  • 2 posts

Posted 30 June 2015 - 07:57 PM

It's one of the pinned topics so it always stay at the top of the page. That's a bummer about the logs though. Guess I'll just make a note for myself then. Thanks!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users