Quantcast

Jump to content


Photo

[Guide] Boost Key Quest Performance In Firefox


  • Please log in to reply
42 replies to this topic

#1 Tailwind

Tailwind
  • Win points = 2,235,563



  • 2,576 posts


Users Awards

Posted 06 July 2009 - 08:16 PM

We all know how goddamn annoying Keyquest is when Firefox wants to lag. To fix it, read on~!

Posted Image


After getting aggravated over Key Quest running at a snail's pace on my computer (WITH 8GB of RAM, shit shouldn't happen!) I finally decided to do something about it. These steps may or may not help those of you with lower end computers, but hey, it's worth a shot. It sure as hell helped me, and now both Firefox AND Key Quest run like a dream.

Bit of a warning though. Follow these directions VERY CAREFULLY. Screwing up could potentially mess up how Firefox runs, which in turn could make things worse.

--------------------


1.: Of course, common sense here. Update your Flash Players to the latest update. Believe it or not, it actually DOES help.

2.: Limit your memory cache. Yeah, I said it. By default, Firefox doesn't do this. More advanced users may have already limited theirs, but for those of you who don't know the under the hood workings of Firefox, I'll help you along.

Type about:config into your address bar and press enter. Click on the 'I'll be careful, I promise button!'. You are now in the inner workings of your browser.

In the new page that just opened up, type browser.cache.memory.enable into the Filter bar at the top of your screen. Once it singles out the filter you'll want to check the boolean value. If it's set to true, then good! If it's set to false, set it to true by right clicking, and then selecting Toggle.

Now, right click anywhere in your about:config page and select New -> Integer. In the new box that comes up, type in browser.cache.memory.capacity. After you have done that, a new box will show up, the number you type in here will depend on the amount of RAM your system has.

256MB of RAM or less: 4096
512MB of RAM: 8192
1GB of RAM: 16384
2GB of RAM: 32768
4GB of RAM: 65536
8GB of RAM: 131072
Basically for every step up you double the number.


3.: Install and enable the RAMBack addon for Firefox. It is located here. What this does is let you clear out the internal caches for Firefox. You can do so by clicking Tools, and then Clear Caches.

4.: Play Key Quest! You should notice a difference in the smoothness of the game and how fast it plays.

Edited by Tailwind, 06 July 2009 - 08:20 PM.


#2 jcrboy

jcrboy
  • Oh shit there's a thing here

  • 6,953 posts


Users Awards

Posted 06 July 2009 - 08:32 PM

This could be useful. I've been tempted to run two at the same time because other people suck it hard.

As soon as people know I'm no noob they bail

Even though it's useless... you still get the NP and you don't HAVE TO redeem the non-gold key

#3 Noitidart

Noitidart
  • Neocodex Co-Founder

  • 23,214 posts


Users Awards

Posted 06 July 2009 - 09:02 PM

...... Thanks thanks thank tail!!! I can't play key quest because it lags so much. This tutorial is a MIRACLE!!!

I never knew it was specifically a FF issue.

#4 Tailwind

Tailwind
  • Win points = 2,235,563



  • 2,576 posts


Users Awards

Posted 06 July 2009 - 09:08 PM

...... Thanks thanks thank tail!!! I can't play key quest because it lags so much. This tutorial is a MIRACLE!!!

I never knew it was specifically a FF issue.


Well, I kind of figured it out after noticing that Key Quest worked just fine in IE and Chrome for me. Got sick and tired of switching browsers.

#5 NinjaHax

NinjaHax
  • 111 posts

Posted 07 July 2009 - 05:51 AM

Thank you for letting us know about this.

#6 Felonee

Felonee
  • 14 posts

Posted 07 July 2009 - 03:20 PM

It runs a lot smoother for me now since doing this, thanks!

#7 Tailwind

Tailwind
  • Win points = 2,235,563



  • 2,576 posts


Users Awards

Posted 07 July 2009 - 09:54 PM

No problem. Glad it's helping people. =D

#8 Noitidart

Noitidart
  • Neocodex Co-Founder

  • 23,214 posts


Users Awards

Posted 09 July 2009 - 09:59 AM

I actually installed RAMBoost first and I didn't have to set the membory.enable to true or add a capacity line because it was already done for me. Do you think the addon did this?

Oh edit I do have to add the memory.capacity though

So after I add capcity do I have to restart the browser?

#9 Tailwind

Tailwind
  • Win points = 2,235,563



  • 2,576 posts


Users Awards

Posted 09 July 2009 - 12:26 PM

I actually installed RAMBoost first and I didn't have to set the membory.enable to true or add a capacity line because it was already done for me. Do you think the addon did this?

Oh edit I do have to add the memory.capacity though

So after I add capcity do I have to restart the browser?


Yes you restart.

And no, you had to manually do it. If it was done before then more than likely you already tweaked it somehow. xD;

#10 Noitidart

Noitidart
  • Neocodex Co-Founder

  • 23,214 posts


Users Awards

Posted 09 July 2009 - 12:28 PM

It's weird I thought it ran faster but then I got into hard core and the mini games lag still :(
I did a ctrl+alt+del and FireFox was up to 500,000!! Then I ignored it kept playing and i was up to 740,000. Is this normal?

#11 Tailwind

Tailwind
  • Win points = 2,235,563



  • 2,576 posts


Users Awards

Posted 09 July 2009 - 05:31 PM

It's weird I thought it ran faster but then I got into hard core and the mini games lag still :(
I did a ctrl+alt+del and FireFox was up to 500,000!! Then I ignored it kept playing and i was up to 740,000. Is this normal?


Sadly, yes, that's an issue with Firefox. It's mostly because everyone and their mother has multiple tabs open.

Try surfing with less tabs open, or at the very least close them when playing KeyQuest. It'll help lower Firefox's memory and CPU usage a bit. (I never go past 30,000 with two tabs open.)

#12 Noitidart

Noitidart
  • Neocodex Co-Founder

  • 23,214 posts


Users Awards

Posted 09 July 2009 - 05:33 PM

I had only keyquest open :(

Isn't the addon and the tweaks above supposed to keep it from going that high? :(

#13 Tailwind

Tailwind
  • Win points = 2,235,563



  • 2,576 posts


Users Awards

Posted 09 July 2009 - 05:36 PM

Yeah, they are.. O_o

You've been remembering to clear the internal caches with the addon, right?

Also, how old is your computer and what are the specs? If you don't mind me asking that is.

#14 Noitidart

Noitidart
  • Neocodex Co-Founder

  • 23,214 posts


Users Awards

Posted 09 July 2009 - 05:45 PM

I clear everytime before I start keyquest. It's about a year old. 3 ghz 1gb ram

#15 Tailwind

Tailwind
  • Win points = 2,235,563



  • 2,576 posts


Users Awards

Posted 09 July 2009 - 06:30 PM

I clear everytime before I start keyquest. It's about a year old. 3 ghz 1gb ram


Oof. My computer is a monster compared to yours.

Try setting the memory capacity to the 500MB setting. Firefox will more than likely need to use even less than it should since your computer isn't the greatest (plus, if I know you right, you tend to run other things in the background a lot. :p )

#16 Noitidart

Noitidart
  • Neocodex Co-Founder

  • 23,214 posts


Users Awards

Posted 09 July 2009 - 07:00 PM

I swear I wasn't running anything this time :( lol
I'll try the 500 setting :)

#17 Cyo

Cyo
  • Pauly D

  • 2,559 posts


Users Awards

Posted 10 July 2009 - 12:17 AM

Dude you're using firebug and all those other addons, all that shit makes firefox a fat memory hogger.

#18 Noitidart

Noitidart
  • Neocodex Co-Founder

  • 23,214 posts


Users Awards

Posted 10 July 2009 - 11:32 AM

Oh shoot I didn't realize firebug would do that. How did you know I used firebug? :p

But thanks for the idea I'll disable all my addons before I go into key quest and then report back

#19 Cyo

Cyo
  • Pauly D

  • 2,559 posts


Users Awards

Posted 10 July 2009 - 11:43 AM

Oh shoot I didn't realize firebug would do that. How did you know I used firebug? :p

But thanks for the idea I'll disable all my addons before I go into key quest and then report back


I'm pretty sure you mentioned that in the -insert topic name- topic where you asked if there was a firebug for IE

Edited by Cyo, 10 July 2009 - 11:43 AM.


#20 Noitidart

Noitidart
  • Neocodex Co-Founder

  • 23,214 posts


Users Awards

Posted 10 July 2009 - 01:40 PM

Oh haha dang Cyo you're observative :p
You're right I use firebug so so heavily :p

#21 LeoOzinN

LeoOzinN
  • 80 posts

Posted 30 August 2009 - 12:56 PM

wow... it's faster now :D
thanks a lot




#22 gaelle

gaelle
  • 65 posts

Posted 07 September 2009 - 03:59 PM

wow i'm gonna try that when neopets will be up again. I hope it will work because Neoquest is the only thing that i can't play on neopets because it laggs.

#23 nonotjj

nonotjj
  • 134 posts

Posted 07 September 2009 - 04:03 PM

Well, I kind of figured it out after noticing that Key Quest worked just fine in IE and Chrome for me. Got sick and tired of switching browsers.

mmm... google chrome :)

Thanks for the guide though, I totally forgot about the configs for FF. :)

#24 Brennon

Brennon
  • 929 posts


Users Awards

Posted 25 March 2010 - 10:49 PM

what if my laptop is a 3gb RAM?

#25 talbs

talbs
  • 4,055 posts


Users Awards

Posted 26 March 2010 - 04:47 AM

i need to look into this, however ive been using chrome lately, just havent played KQ with this browser




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users